QuickTip: Eclipse on Ubuntu : java.lang.ClassNotFoundException: org.eclipse.core.runtime.Plugin

Posted on Monday, April 14, 2008

0


This problem occurs if you do not have the JRE from Sun, but you are using the JRE from GNU. To get the JRE from Sun execute the following command

$sudo apt-get install sun-java5-jre

now you should get the JRE installed in the directory /usr/lib/jvm

if you hit $ java -version now you should see something like this

java version “1.5.0_13”
Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_13-b05)
Java HotSpot(TM) Server VM (build 1.5.0_13-b05, mixed mode)

Now your Eclipse Europa should work without complaining.

Advertisements
Posted in: Java, linux